Cloudflare is down
Incident Report for Next Tech
Resolved
Cloudflare has addressed the issue and posted the following postmortem:

"This afternoon we saw an outage across some parts of our network. It was not as a result of an attack. It appears a router on our global backbone announced bad routes and caused some portions of the network to not be available. We believe we have addressed the root cause and are monitoring systems for stability now."

The full incident details can be found on Cloudflare's status page: https://www.cloudflarestatus.com/incidents/b888fyhbygb8.
Posted Jul 17, 2020 - 15:34 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2020 - 14:38 PDT
Monitoring
Our site is now responding to requests again. We will continue to monitor.
Posted Jul 17, 2020 - 14:38 PDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2020 - 14:20 PDT
Investigating
It appears that Cloudflare -- which Next Tech and millions of other websites use for routing and DNS -- is down. This has resulted in a complete outage of our website that we are unable to address ourselves.

We will keep this status page updated as we monitor the issue and receive updates from Cloudflare.
Posted Jul 17, 2020 - 14:20 PDT
This incident affected: Website, Project API, Zapier API, and Sandbox Cluster.