Google Cloud is down
Incident Report for Next Tech
Resolved
Google Cloud is still experiencing degraded performance in the US. However, our services are operational. We will continue to monitor this issue and provide further updates if we detect an impact on our services.
Posted 15 days ago. Jun 02, 2019 - 15:45 PDT
Monitoring
Google appears to have fixed the issue. We will continue to monitor their incident reporting. As of this time, we have not observed any downtime in our product due to this incident.
Posted 15 days ago. Jun 02, 2019 - 13:01 PDT
Update
Google Cloud has identified the issue as relating to their compute engine and have posted a status update here: https://status.cloud.google.com/incident/compute/19003.
Posted 15 days ago. Jun 02, 2019 - 12:36 PDT
Identified
Google Cloud is experiencing major outages affecting thousands of companies (including YouTube, Snapchat, etc.). We are monitoring and will provide updates as we receive them.
Posted 15 days ago. Jun 02, 2019 - 12:16 PDT
This incident affected: Website, Project API, Zapier API, Sandbox Cluster, and Google Cloud Platform Google Cloud Networking.