Expired SSL Certificate
Incident Report for Next Tech
Postmortem

To track SSL certificate renewals, we record the date of their renewal internally to plan ahead for when new certificates need to be deployed.

For our certificate for our legacy codevolve.com domain, we had recorded the renewal date as 11th, but apparently this was incorrect and it was the 6th (today). At 2:40 PM PT our error monitoring alerted us to this SSL having expired, resulting in launches for new projects still using this domain to fail. Projects that had already been launched were not impacted.

The new certificate was deployed by 2:52 PM PT and Cloudflare refreshed their copy of this certificate at 2:57 PM PT.

We apologize for the inconvenience this brief downtime may have caused. We’ll be reviewing all of our SSL certificates again to ensure that we have the correct dates recorded.

Posted Nov 06, 2019 - 15:05 PST

Resolved
The new SSL certificate has been refreshed and things are back to normal!
Posted Nov 06, 2019 - 14:57 PST
Monitoring
We've updated the certificate and are waiting for it to refresh on Cloudflare.
Posted Nov 06, 2019 - 14:52 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 06, 2019 - 14:47 PST
This incident affected: Project API and Sandbox Cluster.